Jump to content
  • Welcome to Recreational Flying!
    A compelling community experience for all aviators
    Intuitive, Social, Engaging...Registration is FREE.
    Register Log in
BirdDog

LightSpeed Zulu 2 Phone Call Issue

Recommended Posts

Hey guys,

 

So just recently joined the aviation world with the purchase of our new Sportstar and I have a question about a headset that I own. The Lightspeed Zulu 2.

 

The headset was working perfectly on the first flight (Made a phone call over bluetooth, no problem) but when we hopped back in the cockpit the next phone call had issues. When I spoke, the caller's volume stayed really low and I missed a bunch of what they had to say for about 3 or 4 seconds and then it came loud again. very annoying as I really could not hear half the conversation.

 

I have searched but can't find an answer to this little issue. :( Any ideas?

 

Cheers

 

John

 

 

Share this post


Link to post
Share on other sites

Assuming the headsets came with the plane, if you don't have the user manual for them, it's here

 

http://www.lightspeedaviation.com/content/lightspeedaviation/file/Zulu2_user_guide_RevA4.pdf

 

Next stop, change the batteries in the controller. Check the settings on your phone, and finally, it might be a signal strength issue. Mobile phones weren't imagined to work from up in the air, they were designed to work on the ground near the cell towers. While flying, we don't necessarily end up as close to the cell towers as we do when driving on the roads.

 

HTH

 

 

Share this post


Link to post
Share on other sites

Hi there.

 

Thanks for the reply.

 

I bought them new, and have the manual. No mention of it.

 

The signal strength is not the issue. It happens when you are on the ground and in full signal.

 

New batteries etc etc.

 

What the problem is - the noise gate that should let go the moment the pilot stops talking, does not appear to be now, so it basically holds my mic open for too long, meaning, I can't hear the other end until it releases. But not sure how to fix it.

 

The Mic sensitivity is good, as the intercom works perfectly - AND - the first call I made with it was perfect! So not sure what happened.

 

 

Share this post


Link to post
Share on other sites

The mics on the Lightspeed, are little round flat discs. They need to be flat side to your mouth. If they get edge on, they will pick up a lot of noise. You can feel the disc through the mic muff. I always check this when I first put the headsets on.

 

 

Share this post


Link to post
Share on other sites

I forgot to add: If you take off the mic muff, there is a little plastic bud on one side of the mic. Under that bud (cover) is the mic gain control, and that side of the mic should be closest to your face.

 

 

Share this post


Link to post
Share on other sites

Ok cool. I will have a look shortly and see what I find.

 

 

Share this post


Link to post
Share on other sites

The Zulus automatically reduce Bluetooth volume when the intercom or radio are in use so you don't miss any important radio calls, to override it you have to press the black (working from memory!) button once or twice.

 

I make a habit of doing it when I first start up (and check it with a call to MessageBank) so that I don't have to fiddle with it if I receive a call in flight.

 

 

  • Agree 1

Share this post


Link to post
Share on other sites

Thanks Guys,

 

I think it might be to do with that black button! I contacted Lightspeed and they were very helpful, so I will have a play when I get back in the bird.

 

Cheers

 

John

 

 

Share this post


Link to post
Share on other sites

I have a similar problem.

 

It 'clips' the first few seconds whenever the other person talks. Nothing to do with radio coming over the top.

 

Bird dog, have you tried unplugging the headset from the aircraft and making a call?

 

 

Share this post


Link to post
Share on other sites

As I said above Aj it is designed to do that and is easy to switch off.

 

Switch on Bluetooth on your headset and wait for it to connect to your phone. Once connected open your music player and play a song or call MessageBank so you can hear when you fix it, say something into your Mike and the music should drop volume for a second or two, once the volume is back to normal press the black button twice and the test again. The volume will not drop once you have done this.

 

 

Share this post


Link to post
Share on other sites

Thanks SDQDI,

 

I'll give it a try.

 

Here is the instructions out of the manual

 

"ComPriority is turned on or o by the bottom-most controller button. With ComPriority on and when radio communications are detected, the volume

 

of auxiliary devices will be signi cantly reduced. To enable ComPriority, turn on the feature, plug into your intercom and talk into the headset microphone while playing music over a wired device. If enabled, your auxiliary music will decrease when you start to talk. During cell phone calls, the other party will be muted, so disable ComPriority before making calls. "

 

 

Share this post


Link to post
Share on other sites

Thanks Guys

 

I will give this a try when I am back at the bird. Maybe This weekend.

 

 

Share this post


Link to post
Share on other sites
On 09/04/2017 at 9:28 AM, SDQDI said:

As I said above Aj it is designed to do that and is easy to switch off.

 

Switch on Bluetooth on your headset and wait for it to connect to your phone. Once connected open your music player and play a song or call MessageBank so you can hear when you fix it, say something into your Mike and the music should drop volume for a second or two, once the volume is back to normal press the black button twice and the test again. The volume will not drop once you have done this.

 

 

Having the same problems, unsure which black button you are talking about 

Share this post


Link to post
Share on other sites
On 12/09/2019 at 9:39 AM, rhtrudder said:

Having the same problems, unsure which black button you are talking about 

There is a button on the controller, at the bottom below the sliders I think.  Its the priority button.  If you don't push this, the call volume will be dropped significantly when radio is detected.  Took me ages to figure it out!  LOL!

Share this post


Link to post
Share on other sites

Below the sliders there is the blue tooth button , then plus and minus buttons that control the music volume, then below them there is another button , is that it, Greg 

Share this post


Link to post
Share on other sites

Hmm... I think so!  I am not near my bird - can you send a photo - I will tell you!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later for your post to be seen If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...