Jump to content

AVMAP EKP IV Not powering up


Recommended Posts

Has anyone had any experience with an AVMAP EKP IV not powering on at all. It has been working fine for the last 2 years and then yesterday when the aircraft avionics were switched on the GPS gave a continual alarm and refused to power on. I have since removed the GPS from the aircraft and tried altnernate power supplies but it still only sits there beeping. I have tried to hold down the power button for 3 seconds to see if it will stop or start (which is the only thing I can think off to do) but with no change. The alarm is 2 short and 1 long i.e. beep beep beeeep and it just continues. Unfortunately it is out of warranty but does have updated software which was done about 12 months ago. Any 091_help.gif.c9d9d46309e7eda87084010b3a256229.gif would be greatly appreciated



Link to comment
Share on other sites

Our AvMap has a nasty habit of doing a similar thing from time to time at the most inconvenient time. You may need to do a RAM CLEAR.


Some of the following info is not in the good book but came from the manufacturer. We carry a laminated copy in our aircraft as most times it fails we are in the air. To restore properly you need to back up any new waypoints and have your flightplan backed up as well before you set off.


Our AvMap is mounted horizontally. If yours is vertical it won't have to be changed as the default settings are vertical.


AvMap Crash










Turn AvMap OFF (may have to cut power)




Turn AvMap ON while holding down any other key.




A new RAM MENU will appear.




Select RAM CLEAR + ENTER, ‘ENTER’ to confirm.








Unit will return to presets and Screen will be in vertical format (image on its side). All user information is lost.










Press MENU one second to display MAIN MENU.




Select SYSTEM SETUP + GENERAL SETUP + LAYOUT HORIZONTAL to change to horizontal format.








Press MENU one second to display MAIN MENU.






















Highlight file to upload, ENTER (for Waypoints & Routes)










Select VIEWED FP from MENU






Highlight required FP, ENTER






MENU, MENU, FLIGHTPLAN – highlight next waypoint then GOTO.














Highlight box to change + ENTER






OPTIONS – select desired item ENTER.






CLEAR to exit.








(NB .. Check BRG & TRK to ensure ref is ‘M’ not ‘T’


















Hope this helps with your problem. Let me know if it works.




040_nerd.gif.a6a4f823734c8b20ed33654968aaa347.gif 040_nerd.gif.818f42a429bd433d10428d88b6b4d49f.gif 040_nerd.gif.a6a4f823734c8b20ed33654968aaa347.gif








Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...