Jump to content
  • Welcome to Recreational Flying!
    A compelling community experience for all aviators
    Intuitive, Social, Engaging...Registration is FREE.
    Register Log in

murrayg

Members
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About murrayg

  • Rank
    Member
  • Birthday 16/05/1957

More Information

  • Location
    Albany
  • Country
    Australia
  1. Hi Mark, You are probably right - The explanation above was the one given to me by Carmo and I am just repeating it (with little actual knowledge on the subject) They did repair mine and they are working fine - but I am sure that there are different problems that require different solutions. If Friarpuk wants to get new ones - then we get into the soft-start debate .......
  2. Carmo Netherlands https://www.carmo.nl/index.php?main_page=index&cPath=493_4686_2711_4618&language=en and https://www.rotax-owner.com/en/rotax-forum/4-general-discussion/4350-rotax-912uls-failure-of-both-cdi-modules
  3. I had the same problem - only noticed when both stopped working when cold. The way to test is to get a heat gun or hair dryer and warm the faulty unit for a while (2 or 3 minutes?) and then try to start off only the faulty unit. If it starts then the problem is that the older Ducati unit develop heat related solder cracks, when the unit heats up it the joint expands and contacts and it works OK. This was described to me by the repairers that I send mine to (In the Netherlands, I can't remember the name but google the part number and repair). It cost about $800 for the pair and took about 2 weeks - they haven't missed a beat since. Bear in mind that this is NOT a certified repair. Beats $1600 each new. Note that they do not dismantle the units, they drill at the right spot and the right depth to expose the offending joints, resolder then fill. Cheers Murray
  4. Hi Folks, I am chasing a (for parts) Becker AR4201 - Mine has a broken (Bleeding) LCD. Cheers Murray
  5. Serpentine may have an instructor - 15 mins from Rockingham
  6. Hi Neil, Thanks for that - it is factory. I will give RAAus a ring and get the answer from the horses mouth - so to speak. Thanks for your help Cheers Murray
  7. Hi Everyone, First time in Western Australia - almost done my RPL. Quick question (for which I can see no answer on the RAAUS site), I have done the L1 maintenance exam - which allows me to maintain my own aircraft. Can I make modifications to the instrumentation - eg Add an EFIS, Fuel flow monitor and transponder? Any info apprectiated. Thanks Murray
  8. Hi, I hope this is the right way to send a PM - I saw in the forums that you have a Sabre - (I have just bought one in WA), and you posted that RAAus were in the process of sorting out the MTOW to 540kg. Was this ever resolved? Regards Murray
  9. Hi, I hope this is the right way to send a PM - I saw in the forums that you have a Sabre - (I have just bought one in WA), and you posted that RAAus were in the process of sorting out the MTOW to 540kg. Was this ever resolved? Regards Murray
×
×
  • Create New...