Jump to content

LightSpeed Zulu 2 Phone Call Issue


Recommended Posts

Hey guys,

 

So just recently joined the aviation world with the purchase of our new Sportstar and I have a question about a headset that I own. The Lightspeed Zulu 2.

 

The headset was working perfectly on the first flight (Made a phone call over bluetooth, no problem) but when we hopped back in the cockpit the next phone call had issues. When I spoke, the caller's volume stayed really low and I missed a bunch of what they had to say for about 3 or 4 seconds and then it came loud again. very annoying as I really could not hear half the conversation.

 

I have searched but can't find an answer to this little issue. :( Any ideas?

 

Cheers

 

John

 

 

Link to post
Share on other sites

Assuming the headsets came with the plane, if you don't have the user manual for them, it's here

 

http://www.lightspeedaviation.com/content/lightspeedaviation/file/Zulu2_user_guide_RevA4.pdf

 

Next stop, change the batteries in the controller. Check the settings on your phone, and finally, it might be a signal strength issue. Mobile phones weren't imagined to work from up in the air, they were designed to work on the ground near the cell towers. While flying, we don't necessarily end up as close to the cell towers as we do when driving on the roads.

 

HTH

 

 

Link to post
Share on other sites

Hi there.

 

Thanks for the reply.

 

I bought them new, and have the manual. No mention of it.

 

The signal strength is not the issue. It happens when you are on the ground and in full signal.

 

New batteries etc etc.

 

What the problem is - the noise gate that should let go the moment the pilot stops talking, does not appear to be now, so it basically holds my mic open for too long, meaning, I can't hear the other end until it releases. But not sure how to fix it.

 

The Mic sensitivity is good, as the intercom works perfectly - AND - the first call I made with it was perfect! So not sure what happened.

 

 

Link to post
Share on other sites

The mics on the Lightspeed, are little round flat discs. They need to be flat side to your mouth. If they get edge on, they will pick up a lot of noise. You can feel the disc through the mic muff. I always check this when I first put the headsets on.

 

 

  • Informative 1
Link to post
Share on other sites

I forgot to add: If you take off the mic muff, there is a little plastic bud on one side of the mic. Under that bud (cover) is the mic gain control, and that side of the mic should be closest to your face.

 

 

  • More 1
Link to post
Share on other sites

The Zulus automatically reduce Bluetooth volume when the intercom or radio are in use so you don't miss any important radio calls, to override it you have to press the black (working from memory!) button once or twice.

 

I make a habit of doing it when I first start up (and check it with a call to MessageBank) so that I don't have to fiddle with it if I receive a call in flight.

 

 

  • Agree 1
Link to post
Share on other sites

Thanks Guys,

 

I think it might be to do with that black button! I contacted Lightspeed and they were very helpful, so I will have a play when I get back in the bird.

 

Cheers

 

John

 

 

Link to post
Share on other sites

I have a similar problem.

 

It 'clips' the first few seconds whenever the other person talks. Nothing to do with radio coming over the top.

 

Bird dog, have you tried unplugging the headset from the aircraft and making a call?

 

 

Link to post
Share on other sites

As I said above Aj it is designed to do that and is easy to switch off.

 

Switch on Bluetooth on your headset and wait for it to connect to your phone. Once connected open your music player and play a song or call MessageBank so you can hear when you fix it, say something into your Mike and the music should drop volume for a second or two, once the volume is back to normal press the black button twice and the test again. The volume will not drop once you have done this.

 

 

Link to post
Share on other sites

Thanks SDQDI,

 

I'll give it a try.

 

Here is the instructions out of the manual

 

"ComPriority is turned on or o by the bottom-most controller button. With ComPriority on and when radio communications are detected, the volume

 

of auxiliary devices will be signi cantly reduced. To enable ComPriority, turn on the feature, plug into your intercom and talk into the headset microphone while playing music over a wired device. If enabled, your auxiliary music will decrease when you start to talk. During cell phone calls, the other party will be muted, so disable ComPriority before making calls. "

 

 

Link to post
Share on other sites
  • 2 years later...
As I said above Aj it is designed to do that and is easy to switch off.

 

Switch on Bluetooth on your headset and wait for it to connect to your phone. Once connected open your music player and play a song or call MessageBank so you can hear when you fix it, say something into your Mike and the music should drop volume for a second or two, once the volume is back to normal press the black button twice and the test again. The volume will not drop once you have done this.

 

Having the same problems, unsure which black button you are talking about 

 

 

Link to post
Share on other sites
Having the same problems, unsure which black button you are talking about 

 

There is a button on the controller, at the bottom below the sliders I think.  Its the priority button.  If you don't push this, the call volume will be dropped significantly when radio is detected.  Took me ages to figure it out!  LOL!

 

 

Link to post
Share on other sites
  • 9 months later...

I use Zulu 2 headsets with my Xcom radio and I like the call priority function so I have no intention of turning it off. My problem is that the incoming calls on my Samsung phone are nearly muted when the radio is receiving but the level of the call doesn't come back up when the radio call finishes. Any clues?

Link to post
Share on other sites

I go flying so people cant contact me!!! They are welcome to try but they will have to leave a message!!! I Aviate, the I navigate, then I communicate........ If i am flying you will have to wait until I get back!! My headphones don't do Bluetooth....

  • Like 2
  • Winner 1
Link to post
Share on other sites

I spoke to a guy in a Foxbat today while he was flying..he rang me. It was very impressive...couldnt really tell at all he was doing 100kts at 3000 ft...not really any engine noise at all

 

Steve throw that android rubbish out and get a very expensive real phone like a Iphone...its just hard to swallow the price...but it does actually work

Link to post
Share on other sites

Steve throw that android rubbish out and get a very expensive real phone like a Iphone...its just hard to swallow the price...but it does actually work

I already have an iPhone but I hate it! Going to move my sim over and try it though. I like Ozrunways much more than I liked RWY so I may have to make the move so I have backup, or I will have to buy a hybrid subscription.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...